Dataset Visibility in SageTV

I run a DVR software call SageTV. I have 3 NASes I am trying to replace with TrueNAS. These are DLink, Lenovo and Buffalo NASes. On all three of these I can connect to shares I have created on them. I have created SMB shares on TrueNAS and can see them in Windows 7 and 10, but when I try to connect to TrueNAS in SageTV I can see the server, but no shares show up. I can map TrueNAS as a network drive and I can get to the TrueNAS shares that way but I really don’t think this is an optimal solution. I have been playing with permissions for the last week and nothing seems to work. I could use some guidance at this point in how to make the SMB shares show up in SageTV.

Can you directly connected to a share?

For example, the full path, such as:

I don’t have that option inside SageTV. Its menu driven. It shows my shares on the network and when I click on the TrueNAS server it shows no shares.

Can you share how to configured the SMB Share in TrueNAS?

Are you sure there’s no option to manually enter a share location in SageTV?

Yes, I am possitive I cannot enter an IP and the share. This works just fine on all my other NASes and they are all Linux based. What do you want to see as to how I configured the SMB share?

Either testparm -s or the screenshot of the individual share (all options viewable.)

I am really new at this so if this is not what you wanted please let me know

You’re sharing the root dataset. You shouldn’t do this. (I thought the GUI prevented this.)

With TrueNAS, you’re meant to create child datasets, save data to them, and then share those out.

I tried that also. No luck. Nowhere does it tell me this. I have been reading documentation all this week.

How did you configure the ownership and permissions for this dataset?

I can’t show everything but here is part of the screen

If you go to Services → SMB → and “Enable SMB1 support”, then try again, does it work with SageTV?

1 Like

Yes, that seemed to work. I did not know about that option. Since everything was working in Windows 7 and 10 I thought the SMB service was working as intended. Thank you so much. I’ve spent nearly a week trying to work this out on my own.