Hi all !
I’m really struggling to get my install working and can’t find the answer in the forum despite looking,…
I had it all running with Truenas Core then migrated, so here’s the config:
- Truenas Scale latest update
- Installed NPMplus for the reverse proxy with ports 80 and 443 redirected in my router to My_TrueNAS_IP:NPM_port_#
- Installed Nextcloud (all seems fine from the logs, though I have not yet been able to reach the home screen due to the issue below)
- my.domain.ovh is registered at OVH and dynamically redirecting to my public IP.
- I have a wildcard certif. generated by letsencrypt with the OVH plugin, all done via NPMPlus interface
- Created a proxy host in NPMPlus with cloud.my-domain.ovh redirecting to My_TrueNAS_IP:nextcloud_port_# and using the certificate generated
- I have installed Pi-hole to setup local DNS records npm.my-domain.ovh pointing to My_TrueNAS_IP and CNAME records with cloud.my-domain.ovh pointing to npm-mydomain.ovh (though I must admit I don’t fully understand what that’s used for).
But when I try to access cloud.my-domain.ovh, I get:
cloud.my-domain.ovh has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.
[…]
Because there’s an issue with the site’s certificate. Sites use certificates issued by a certificate authority to prove they’re really who they say they are. This site’s certificate is self-signed. It wasn’t issued by a recognised certificate authority – so we don’t trust it by default.
And when I try to get direct access using My_TrueNAS_IP:nextcloud_port_#, I get:
An error occurred during a connection to 192.168.50.246:30027. SSL received a record that exceeded the maximum permissible length.
[…]
Error Code: SSL_ERROR_RX_RECORD_TOO_LONG
I’ve logged into the NPMPlus console, and manually generated a certificate using:
certbot certonly --preferred-challenges dns-01 -d my-domain.com -d *.my-domain.com --server https://acme-v02.api.letsencrypt.org/directory --rsa-key-size 4096 --staple-ocsp
I got a certificate, copied it where NPMPlus saved the other but it has had no-impact whatsoever.
When I look at the certificate, when Firefox gives me the error, a line under validity says:
Not Before Sat, 12 Sep 2026 21:39:29 GMT
Not After Fri, 13 Jan 3026 21:39:29 GMT
I guess year 3026 is the translation of the ‘permanent’ validity I had selected on OVH API, but just wondered if that was part of the cause ?
Otherwise, I don’t know how to proceed further. Any help welcomed !!



