Thunderbolt 3 JBOD Support in Truenas

I am using several OWC Thunderbolt 3 storage solution with Truenas Scale Dragonfish-24.04.0, everything is working as expected and I am very pleased. However when I upgrade to Dragonfish-24.04.1.1 my Thunderbolt drives are not detected, anything changed in these updates thats resulting in this behavior? Based on what I read debian 11 supports it natively Using Thunderbolt on Linux

The kernel changed.

You can try a 24.04.2 nightly build, where the kernel has changed again, to fix issues with the previous kernel change.

I see, so I assume the next stable release will fix this? I dint see anything in the release notes about thunderbolt changes…

You are unlikely to see any references to thunderbolt in release notes because I doubt it is something IXSystems test at all. In any given release it may or may not work (I would tend to bet on not being more likely). If you want something that is going to use a connection type that is tested you will want a SAS Enclosure. You will of course need a HBA, or perhaps a SAS expander depending on your existing setup, in order to connect to such an enclosure.

2 Likes

Yeah I have been using supermicro servers and jobod expanders for past several years, infact one of them I bought for truenas store. Having said that if you have not tried thunderbolt3 jbods, please give it a go, its faster and stable and consumes 80% less energy.

1 Like

Found these useful link from old forum:

  1. TrueNas Scale Thunderbolt 3 Storage Enclosure Support

  2. Thunderbolt support in TrueNAS SCALE

How do I update to nightly? I dont see option to switch the train in the ui :frowning:

Aside: I think you’re talking about these NVMe type NAS’ I’ve been checking out today. I don’t know much about these devices but they look/sound like a nice option (small, minimal electrical, etc). Not that it matters but FreeBSD supports Thunderbolt apparently (just did a google and the first link I clicked on the person talked about this type of setup on 13.2 and 14.0).

Quote:
"…Displayport port for a monitor and a ZFS pool for /usr/obj builds. The enclosure is populated with four (4) Intel 670p 1TB drives.

Storage and external monitor worked on 13.2 and is working with 14.0p3."

I’m getting tired of the runaround from TrueNAS so I may just go standard FreeBSD myself. Good luck with the nightly build though; that’s too risky for me (I prefer stable).

There are links to download nightly builds here Software Releases | TrueNAS Documentation Hub. When you get to the Storj downloads page, you can control+F 2024062 to find the most recent nightly.

I am not going to run the actual cluster, just want to test if the issue is resolved.

Thanks and I believe its the .update file not .tar right?

Vote to fix this:

NAS-129765: Nightly’s should be ordered chronologically or [reverse] alphabetically

2 Likes