TrueNAS SCALE 24.04.1.1 is Now Available!

We are pleased to release TrueNAS SCALE 24.04.1.1!

This is a maintenance release focused on two high-impact issues found in 24.04.1:

  • Apps Service (Kubernetes) times out waiting for network interface (NAS-129150).
  • Apps menu selected by a Read-only Admin user fails with traceback (NAS-129187).

See the Release Notes for more details.

Changelog: https://www.truenas.com/docs/scale/24.04/gettingstarted/scalereleasenotes/#240411-changelog
Download : https://www.truenas.com/download-truenas-scale
Documentation : https://www.truenas.com/docs/scale/24.04

5 Likes

Appreciate the quick fixes :heart:
Upgrade smooth and easy as per usual.

3 Likes

Intel GPUs are still broken with Jellyfin but that’s unsurprising seeing how it’s a very small release that doesn’t cover that issue.
See [NAS-129293] - iXsystems TrueNAS Jira
Also, it’s a only friendly suggestion, but it might be a good idea for iX to purchase something like a cheapo Arc A380/A310 card for their hardware testing rig :slight_smile:

2 Likes

Yea, I will have to grab us some. A bit surprised at how many folks have them in the wild right now :slight_smile:

3 Likes

AFAIK they’re the only reasonably priced consumer cards that do proper AV1 encoding, the other less reasonable ones being RTX 40 series and RDNA3

2 Likes

I saw some comments and verified my Arc A380 is still functional for HW transcoding in Plex with the latest update. I DID manually copy some files during the RC or initial Release. I don’t know if these files are kept when updating, or if an update would replace/ignore them.

The Arc GPUs have a few benefits: AV1 encoding, cheap, low profile options, gets power from the PCI-E slot. I agree it would be cool if iX splurged $100 to buy one for verification :slight_smile: I’m not sure they’d be popular with the enterprise customers, but I can see these being popular with the home users.

EDIT: I just realize this is a new release. I thought there were a lot more comments when I looked earlier. Let’s try this…

2 Likes

That fixed the issue with my apps, too.

Thanks for the quick reaction.

1 Like

It’s also what Jellyfin straight up recommends as the go-to GPU for transcoding not just based on price, but from technical standpoint too. And the person who does ffmpeg stuff for them focuses on optimizing for Intel’s QuickSync first from what I’ve seen.

2 Likes

Hey that was fast! I’m sure a lot of people are very happy that iX was able to correct the problem very quickly. I’m about to do my update now.

2 Likes

I’ve been evaluating gpus to add to my systems.

Under all considerations the intel ones keep on coming out on top.

And they are not opposed to SR-IOV

I dunno. So much cheaper for VDI :wink:

https://www.intel.com/content/www/us/en/products/docs/discrete-gpus/data-center-gpu/flex-series/overview.html

If anyone is interested in providing access to their TrueNAS system, so we can work on investigating why transcoding isn’t working for these Intel ARC GPUs, that’d be cool :slight_smile: . I’m not saying we can immediately jump onto your system, I’d have to find time in my schedule (and yours of course) but it’d help me greatly if I could at least lay eyes on a system that isn’t working.

EDIT: DM me so if you’re open to this idea.

2 Likes

@csj Maybe kernel issue?

I’m not open to providing access to my TrueNAS system, however transcoding has been working for me since I used a fix detailed way back during the RC. I needed to enable developer mode on TrueNAS to be able to make the modifications, find the correct files, put them in the correct location, and nothing else. I believe the boot logs showed which files were missing/problematic, and those are the ones I loaded. I am willing, however, to run any commands that people would like me to run.

Gosh, and we’ve been spending so much on Nvidia hardware instead :slight_smile:

I had to switch back to 24.04.0. On both 24.04.1 and 24.04.1.1, the Dashboard, Boot, and some other pages would fail to ever load. Yes, I cleared my cache, tried a different browser, tried private windows, tried different systems. If you caught it immediately following a boot, you could get the page to load, but once TrueNAS was fully ‘loaded,’ I was no longer able to access these things.

On 24.04.1 All apps started up at boot, but I was unable to stop/update them. The job would just run forever (or at least an hour) without completing or making any progress. I didn’t test if this was the case on 24.04.1.1 since the other behaviors were similar.

Symptoms seemed similar to the issues on Dragonfish that were fixed by increasing certain sysctl limits. Going to diff the sysctl settings to see if anything limits changed between versions. Otherwise, no clue what’s up…

I’m still unable to ‘stop’ the apps that started without issue at boot, however they are showing ‘untolerated taint.’ I’ve seen others discuss taint woes with TrueCharts apps, so I’ll lay the problem at their feet and seek the fix.

Now, to verify once more that my Plex hw-accelerated video encoding is working just fine on the latest version. Stay tuned.

Hi, since update to 24.04.1.1 the web interface does not work anymore, nor my VM where my docker apps are hosted.

When rebooting on 24.04.0 everything is working fine after flushing the dns cache (using unbound on opnsense).

Weird…

Seems likely you’ve already tried, but have you cleared your browser cache?

I was using firefox and tried microsoft edge and it was the same problem.
I didn’t try to clear firefox cache though.

If it doesn’t load, I’d recommend raising a bug report, if you can check the console log and see if there are any obvious errors and include those. If not a bug report would be really helpful for us to investigate, if you have console access debug can be created from the TrueNAS CLI through:

system debug > debugname.tgz

The file can be collected via SFTP from /home/username/

Thanks for your help
As I’ve updated opnsense today to the last version (24.1.8), I’m also considering as a culprit :slight_smile:
I’ll try to send you the system debug as well.

1 Like