TrueNAS SCALE 24.04.1 is Now Available!

coming from TrueNAS-SCALE-23.10.2
whats the feeling… should I pull the trigger ?
you guys got more experience.
see some issues, then some ppl not having had any problems.
run a couple of TrueNAS containers/Apps and TrueChart based apps, like Unifi and Plex.

after upgrading 3 systems, two of which the dashboard is empty

If you haven’t already try clearing the browser cache. If you have are there any errors in the Browser console?

If you’re running truecharts apps you have to migrate them to their storage backend since dragonfish removed the buildin openebs implementation form iX and truecharts uses openebs for their pvc storage. They have a very good migration guide and script which made the migration pretty painless for me. Took me like 2 hours on a saturday to migrate 30 apps. Your apps will still function, but wont be able to install new apps without the truecharts openebs app installed and configured.

1 Like

clearing browser cache worked for one system. the other I had to manually configure the dashboard.

glad to see you say the apps will continue, working as is… just blocking me from installing new… which means i can do this in the next couple of days, when family not using apps.


There will be a hotpatch to released today that fixes the two major issues found:

Description on network breaks Kubernetes - NAS 129150

Apps menu fails for a read-only admin - NAS 129187

Now out: TrueNAS SCALE is Now Available!

1 Like

Just tried to upgrade my install from 24.04.0 to 24.04.1 to get the fixes for the ZFS ARC problems and I’m getting this error now. No matter what I tried I could not get the app services to start. My br0 is up and running just fine as that is my primary interface for traffic and all other services and virtualization are working just fine. I feel back to my 24.04.0 and app services started up just fine. It seems something is just not quite baked right with 24.04.1.

Screenshot 2024-05-29 at 2.59.03 PM

Update to - it has literally just gone up as an update, has the fix for this.


Doh! Will try it now.

I am not sure how the guy above had working DG2 HuC firmware, I had to install the file manually myself, but I too also can’t get transcoding to work in Jellyfin with the latest .1 with my A380.
I thought it might be because HuC firmware is newer than what I had on 24.04.0, but manually downgrading the HuC firmware to the same version as the one I manually installed under 24.04.0 did not help. And either version loads fine in dmesg. I’m a bit out of ideas what might be wrong.

Do you know perhaps how to check the compute runtime version? I couldn’t really find the answer online

The TrueNAS SCALE announcement is out. See TrueNAS SCALE is Now Available!.

Only way I know of on Debian requires apt access. So dev mode. Etc. That’s assuming my thoughts above are.correct. I’m not actually in a position to test my self directly at the moment.

I added whichever file(s) were missing for my Arc A380 to work either during the RC or the first release for Plex transcoding. I haven’t made any further changes, and Plex transcoding continues to work on 24.04.1 and If there’s any commands you’d like me to run to tell you which I’m using, just let me know. I don’t remember what I did that far back :slight_smile:

I have been having issues with my A380 since 24.04.1. I had no issues under 24.04.0, i had copied the missing firmware file and updated /etc/modprobe.d/i915.conf to include guc=3, but under 24.04.1 even after repeating the above changes i can’t get any transcoding in jellyfin to work, it also affects my cameras ffmpeg processes in Frigate.

After some digging around i came across the following issue which seems to be exactly what i am experiencing, i think the problem is in the kernel version 24.04.1 is using.

I had the exact same issue - Plex App not reporting stats on 24.0 reported here

It was closed (can’t fix)

Can confirm fixed the apps not starting issue for me (despite having no interface descriptions).


Could you reply on this issue please? Thanks

I left my comment in the both Jira tickets:
Plex usage stats are broken once an Nvidia GPU is attached to Plex App pod.
If an Nvidia GPU is removed from the Plex app configuration stats show up again:

Perhaps iX dev guys can see this