Unable to install SCALE, able to install CORE

I am using Rufus:
MBR
BIOS or EUFI
FAT32
DD mode

I find it very weird that I can install core and not scale

Since I am writing this usb flash drive exactly the same for core and scale

Assuming your issue is booting into the installer…

I would suggest disabling CSM, and installing UEFI if you get the chance.

Otherwise, try writing with a different program.

I used Balena Etcher last time.

https://ubuntu.com/tutorials/install-ubuntu-desktop#3-create-a-bootable-usb-stick

I already tried all of that, installing with CSM enabled and disabled. And UEFI. I also already tried balenetcher.

I even updated the bios last night. Did not fix it

I do see the blue screen were the installer asks for the normal or 152000 baudrate. After that, a blinking cursor in the top left and after that the error.

Assume your BIOS is all up to date? 3.40? https://pg.asrock.com/mb/AMD/B550%20PG%20Riptide/index.asp#BIOS

yeah, installed it as an option, did not fix it.

Ok, you’ve test booted that same USB on another system? Does it boot up and the SCALE installer starts?

For what its worth, it should be written in dd mode specifically using Rufus.

I installed scale on an older system using the exact same USB.

Yes, i do see the blue screen with the baudrate option.

yes, I am using DD mode in Rufus

Ok, to further narrow this down further. Have you done the following:

  1. Downloaded generic Debian 12 USB, does that boot on the system?

  2. Download the 23.10 (Cobia) SCALE image (Older kernel)

Do either of those boot?

1 Like

I will try these later today

Installing version 23.10.2 gives my the same issue.
Installing version 22.12.4.2 gives me: FIPS self test failure.
Debian 12.5.0 actually did install

That is a fascinating result. I assume you’ve gone through and tried resetting the factory default UEFI / secure boot keys? Could you provide a screenshot of your boot/UEFI settings page in the BIOS?


I did reset the BIOS to default and reset the secure boot keys

Can you enable CSM and get us a screenshot of the boot keys / secure boot page?

So what’s the problem exactly?

thug-winnie


You might be surprised, but creating a Ventoy bootable USB can miraculously boot ISOs that would otherwise give you issues.

It has two “modes”. Each ISO is allowed to boot in “Regular” or “Grub 2” mode.

  1. Create a Ventoy stick
  2. Copy the .iso file directly to the FAT32 partition, which is labeled VENTOY[1]
  3. Boot from USB (preferably disabling CSM and “Secure Boot”, using pure EFI)
  4. Select the TrueNAS SCALE .iso file from the menu list
  5. Try booting it in Regular mode. If it fails, reboot and try again in Grub 2 mode.

  1. When you create a bootable Ventoy USB, the stick will have two partitions. One is the actual Ventoy bootloader and software, while the other is a plain empty partition (the remaining capacity of the stick) where you simply copy ISOs directly into it. No need to “dd” or use any fancy tools. You can dump dozens of bootable ISOs into a single USB stick, rather than wasting an entire stick just for one ISO. ↩︎

1 Like

The problem is that it doesn’t support his NIC:

The better answer is to use a better NIC. But SCALE was suggested as an alternative.

1 Like

Thank you all for all the replies, eventually I got it working yesterday and Truenas Scale actually does support my NIC.

Later today or tomorrow I will go into the BIOS and see what my exact settings turned out to be. So I can post it here.

3 Likes

Glad you got it booting! It would be good to know what magic combination of settings enabled booting for later readers who might have similar hardware :slight_smile: (And I’m just curious now)

1 Like

So basicaly everything is off:
CSM is off.
Secure boot is off.
Fast boot is off.

I did reset the secure boot keys so maybe that was something