Kernel Panic..Stuck at NO Idea What Stage

Hey Guys,

Really need some helps and advise here.

I just got some used hardware from a friend, previously he was using it to run some crypto project with Ubuntu.

When I tried to install Truenas Scale (latest) on it , I encountered errors, which I don’t know how to describe it (please help to take a look at the screenshot attached).

I tried BIOS firmware update and reset (without issue). I don’t know what to do next…

The motherboard is Aorus TRX40. 2 32GB RAM. So far I only attached 1 ssd to get the Truenas install on it…

Thanks in advance for those who willing to share some thoughts.


Your initramfs is corrupt.

Are you booting the ISO from a UBS? Did you verify the checksum of the ISO before you flashed it ( / loaded it, if using ventoy)?

Thanks for your reply.

Yes. I was booting the ISO from a USB. End up is the motherboard issue. The moment i switched to another pc for setup, I’m in TrueNAS within 15mins.

Will just put aside the problematic motherboard to try again in near future, see what’s the problem. I did some google, seems like need to play with the RAM installed.