Pool imported but dataset unable to mount after sudden loss of power to drives

Do you have a good backup of all your data?
TrueNAS virtualized on Proxmox needs to be done like a production server. You pass through an entire controller, like a HBA, and blacklist the controller from Proxmox so it doesn’t attempt to mount the ZFS file system. See last link

The other, possible issue is your ASM1166 SATA controller. It is listed as a ‘port multiplier’ and may not be a good fit with ZFS (TrueNAS)

You should have a real HBA.
What’s all the noise about HBA’s, and why can’t I use a RAID controller?

Multiply your problems with SATA Port Multipliers and cheap SATA controllers